HL7 Processing Delayed
Incident Report for HealthPay24
Resolved
Systems remain at normal levels. We will continue to monitor.
Posted Dec 22, 2023 - 11:36 EST
Monitoring
Services have been restarted and we are seeing normal activity. We will continue to monitor and report any updates.
Posted Dec 22, 2023 - 11:10 EST
Investigating
We are currently investigating this issue.
Posted Dec 22, 2023 - 10:56 EST
This incident affected: EDI Services.