HP24 Availability | Azure Cloud Availability Issue
Incident Report for HealthPay24
Resolved
This incident has been resolved for HealthPay24 services, despite Microsoft continuing to show some degradation. Additional details will be shared as they're made available from Microsoft.

If you notice any additional issues, please use your usual channels of contacting HealthPay24 Support to generate a ticket. Thank you.
Posted Jul 18, 2024 - 23:16 EDT
Monitoring
HealthPay24 services are operational, as of approximately 09:50 PM Eastern.

We will continue to monitor and provide updates as needed.
Posted Jul 18, 2024 - 22:45 EDT
Update
Update from Microsoft:

"We’ve determined the underlying cause and are currently applying mitigation .Customers should see signs of recovery at this time as mitigation applies across resources in the region. The next update will be provided in 60 minutes, or as events warrant."

Consistent with this update, we're seeing the majority of services returning to normal, though not fully restored.
Posted Jul 18, 2024 - 22:20 EDT
Update
Microsoft continues to work on a fix for this issue. We will continue to update here with any noteworthy changes.
Posted Jul 18, 2024 - 21:18 EDT
Identified
The issue has been identified by Microsoft and restoration is in progress. There is no ETA for completion.
Posted Jul 18, 2024 - 20:08 EDT
Update
All HealthPay24 components run on Microsoft Azure. Azure is experiencing intermittent reboots and availability issues. There is currently no ETA on restoration.
Posted Jul 18, 2024 - 19:25 EDT
Investigating
We have received monitoring alerts and are investigating possible Microsoft Azure issues.
Posted Jul 18, 2024 - 18:32 EDT
This incident affected: Provider Portal, Patient Portal, Partner Portal, Payment Gateway Services, API Services, Epic Services, and HealthPay24 Classic Services.