Possible Firewall Issue | Link to vendor incident status
Incident Report for HealthPay24
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 07:11 EST
Update
Vendor has applied a fix and is monitoring. We will also continue to monitor into the morning.

As a reminder, details of the incident can be viewed at
https://www.cloudflarestatus.com/incidents/xnjgjjs53lg8
Posted Jan 17, 2024 - 22:52 EST
Monitoring
Some clients have reported issues accessing HealthPay24 from virtual services or remote sites. While we're not seeing issues with the HealthPay24 sites themselves, our firewall vendor, Cloudflare, has issued an incident report on their status page which may be relevant.

For the latest updates, please visit CloudFlare's status page at https://www.cloudflarestatus.com/incidents/xnjgjjs53lg8
Posted Jan 17, 2024 - 20:58 EST
This incident affected: Provider Portal.